Graph integration is active but not active


I have transferred my project as explained here: General Settings > Advanced > Transfer Project.

However, there was an additionnal issue: I had “Project cannot be transferred, because tags are present in its container registry.” Reading here again, I thought it was fine as it worked before, deleted the tags, then transferred the project.

However, now, I have “Knowledge Graph integration not active”. 404 not found when I try to create a new session.

And when I go to ‘Overview - Status’ to activate the graphs it is all green with “Knowledge Graph integration is active.” at the bottom.

Long story short: I can’t find a way to re-activate the graph integration as it says the graph integration is already active.

If it can help, it is this project: Renku. that I moved from my name to DSCC.

Do you have any advice to re-activate the graph integration in the new name space ?
Thank you :slight_smile:

Hi @PaulineML,
To reactivate Knowledge Graph on your project you need to do few steps:

  • if you go to Overview - General you should be able to see a View in GitLab button.
  • Once you are on the GitLab page you can navigate to Settings - Webhooks.
  • On the bottom of the Webhooks page try to locate a Project Hook pointing to and remove it (the link of the Hook should look like
  • Go back to the Overview - Status on the Renku UI
  • At that point, you should see the Activate button under the Knowledge Graph Integration section.
  • Click the button to start the activation process. A progress bar should be shown to you and when the process is finished, the green message Knowledge Graph integration is active as you saw before.

I’m hoping that helps.

Hi @jachro, thank you it worked to remove the warning of the integration graph.

However, I still have 404 not found when I try to open my session.
(and before there is an orange warning: Image source: renku/renkulab-py:3.9-0.11.0
Warning: a fallback image was used.)
These were the last session logs if it can help:

[I 11:02:04.244 NotebookApp] Jupyter Notebook 6.4.5 is running at:
[I 11:02:04.244 NotebookApp] http://pauline-2e-metadata-2dauto-2dr-2dli-1b0a14a7-0:8888/sessions/pauline-2e-metadata-2dauto-2dr-2dli-1b0a14a7/
[I 11:02:04.244 NotebookApp] Use Control-C to stop this server and shut down all kernels (twice to skip confirmation).
[I 11:02:20.852 NotebookApp] 302 GET /sessions/pauline-2e-metadata-2dauto-2dr-2dli-1b0a14a7 ( 2.280000ms
[W 11:02:20.975 NotebookApp] 404 GET /sessions/pauline-2e-metadata-2dauto-2dr-2dli-1b0a14a7/rstudio? ( 78.310000ms referer=None

1 Like

@PaulineML since you removed the images from the registry when you transferred the project, you need to rerun the image-build pipeline to push the image there again. If you go here and click Run Pipeline it should correct itself. I think you’ve discovered an edge case with image availability that we are not handling very well yet, but improvements are on the way :slight_smile:

It works perfectly now!

Thank you @jachro and @rrrrrok for your quick help :slight_smile:

1 Like