Importing dataset: resource not in KG

I am trying to import a dataset into another renku-repository, like this:

renku dataset import

But this gives the following error:

Error: Resource not found in knowledge graph:

There seems to be something wrong with the knowledge graph in the repo, but I am not sure what goes wrong.

Hi. I believe the import dataset does not work for you as we’re still busy processing metadata of your project to load it into the knowledge-graph. You can monitor the progress here, but unfortunately, at the moment the knowledge graph provisioning for big projects like yours is very slow. Sorry about that.

The knowledge graph is still at 94% and doesn’t show yet. Do you think it will finish eventually?

You are right. I have to admit it takes a very long time. We are doing our best to speed up the knowledge graph provisioning process but unfortunately, we are not there, yet.

Okay, and in the meanwhile, can I add import data in a different way? I tried for example:
renku dataset add img --source data/img_tech_note/ git+ssh://

But that gives an error:

Error: Cannot clone remote Renku project: Git exited with code 128 and error message:

Afterwards, I tried it like this:

renku dataset add img

And that actually worked, but not sure if that is a proper way of doing it.

Ah, it actually also works like this:

renku dataset add img --source data/img_tech_note/3_changes.png

The path behind source was wrong…