Can't add dataset to project

I have two private repositories both owned by me. In one I have created a dataset. I can’t import this dataset into the other repository. If I try to do it via CLI, i get:
renku dataset import Error: Resource not found in knowledge graph:

If I try to do it via the frontend (dataset->‘Add to project’ Button → Select correct Existing project → ‘Add Dataset to existing Project’) I get:

The renkulab.ui frontend clearly states that the dataset is contained in the knowledge graph. Please fix this or tell me what I’m doing wrong as I can’t really work with renku if this doesn’t work. The dataset is not yet published and the repo needs to remain private.


Hello @jkminder,

Thanks for your feedback, we will make this process more intuitive soon.
For now, you need to clone the repository on your machine and use renku login before you can import your private datasets in the CLI. Once logged in, your import command should work as expected. Importing private datasets in the UI is not yet possible.

Thanks! I’m working on a remote, headless compute server. So far I have been using renku via ssh keys. If i try to run renku login it states that I should open a browser. As the machine I’m working is headless this is not an option. I am also not really keen to work with some kind of terminal browser if that even would work.

I think for the moment I can clone my work to my local machine, login in the renku CLI via browser, import the dataset, push and then pull the imported dataset onto our cluster. I hope this will work.

I’ll add a new issue regarding the login, I think this is really important and probably better if this is its own issue.