Unsaved work problem

I have a big problem. Yesterday my computer had a problem and this morning I tried to resume the session but it gives me some error with the Docker File, although I did not change it and it worked before.
Currently I have some unsaved work in my session, and I was wondering if there is a way to recover the data or I should simply surrender and accept that I lost some files.

Thanks in advance!

Hi Nic,

Can you tell us what the error says, please?



I cannot see the error message exactly, Renkulab only tells me the following:
The server shut down unexpectedly. Please ensure that your Dockerfile is correct and up-to-date.

I’m downloading some models before I enter the session. Maybe those are slower than usual and Renku shuts down. If I look at the logs I see that the models are still downloading and cannot find any error message.

I can see that the session is still starting up and pulling data from your repo, I will keep on eye on it, but I assume it should be ready to connect to shortly

Yes, I’m also seeing that something is happening, it seems to work. It is extremely slow compared to other times, I will have to improve it.

We believe it could be the post-init script. Would you like me to comment out the lines in the script, so that the session can start?

Yes, the post-init is the problem.
Do I lose the uncommitted files if the post-init script is modified and the session restarted?

I can modify the script in the running session, which will preserve the unsaved files. I‘ll do that now.

Perfect, thank you.
Should I pause the session and resume?

No need to, I think it should be possible for you connect now. Do you mind confirming that for me, please?

Yes, I could connect to it.

Thank you very much for the help

1 Like