"start session" interface is stuck after August upgrade

I am coming back to my projects after the recent renkulab upgrade in august 2023, and I have a problem with reviving the projects, one example is astronomy/mmoda/gaia. If looks Ok when I just look at the files, but when I try to run a session, the frontend is stuck at “getting project settings” (flashing in web browser).

@andriineronov can you please post a link to your project?

@andriineronov this is a bug we are working on resolving. I will get back to you with additional details as soon as possible.

just to document and in case this helps trouble shooting. We are observing the same bug in this project.
Thanks for looking into it!

@andriineronov The issue you’re having is that the .renku folder was deleted in your project in commit 956cdf27a68cbd6a148d715fd3122f428b52bf56, which is required for a Renku project. That merge is really weird, merging main into main with many files deleted, I can’t really understand what was done there.

The bug @tolevski mentioned above is that when we tried to renku init --force the folder back into existence, those changes didn’t show up in the UI due to a caching problem on our side. So that fixes it (though of course all renku metadata would be gone, as it was deleted), the issue is that the fix doesn’t show up in the UI.
But deleting the .renku folder is the root cause of you’re problem.

@Almut since your project has a .renku folder, it is unrelated to this. it looks like a UI error, we’ll look into it

I certainly did not do this commit. How do I restore .renku folder? Or you re-try renku init?

I am still not able to re-start the project…

Hi @andriineronov - I forked your project, cloned it locally and re-initialized it, and now it works. I had to restore the requirements file as well. You can see the commits here: Commits · main · Rok Roškar / gaia · GitLab

I can synchronize my branch with your current project and make a pull request, if you want?

@andriineronov I tried to restore the project and override the effect of those bad merge commits… which resulted in a funny git history, but I think it’s all there now - could you have a look at

Yes, it looks Ok, thanks. Is the way to proceed to “delete” the previous project and fork to a new project from your fork? Or you would just copy the .renku directory from your forked project back into the original and it would be “back to life”?

I believe you could probably merge my project into yours. I can try to make a pull request - if that complicates things even more, we can also force push my branch to your project

Ok, let’s go with the pull request

I merged from your pull request, but the problem persists. If I try to start session, the “getting project settings” part in the bottom of the webpage is blinking permanently…