The target project is not a Renku project?

I have a very strange isssue with one of my projects

It complains that it is not a renku project, it cannot establish the renku version, there is no template
However, I used
ARG RENKU_BASE_IMAGE=renku/renkulab-py:3.10-0.22.0

I cannot change setting either. However, in gitlab, I can change settings and I see that the image was built.

Can you help me?



It looks like this repository wasn’t actually created using renku. It has a .renku directory but that is missing all of the renku metadata and the commit that created that directory was done manually, not by Renku.

To be a renku project, it needs the renku metadata store, which gets created by either using the cli renku init . or when creating a new project through the UI.

You can initialize it now using renku init --force ., but be aware that this will also overwrite your dockerfile and potentially other files (the command should tell you which ones when running) and youd have to add back in any changes you might have made to those files previously

Thank you !!

This solved my problems. I was confused because, locally, “renku session start” worked.

However, I found out that “renku migrate” did not work while following your suggestions with a bit of liberty.

May I suggest to expose with more verbosity the reason of failure of test failures and possible ways out? I think that if in the error message, you added the second and third paragraph of your message, I would have found out by myself how to proceed.

1 Like

glad to hear it worked.

I’ve opened an issue on our end to improve the error message to point users in the right direction, thank you for the suggestion!