Docker image build failed - Job failed

I tried starting a session with this repository and got this error.

I found several similar posts with this error but when I looked into the ‘view pipeline on git’ the error was not clear.

I am unsure of how to continue from here to be able to make a session with this repository. Thank you in advance for the help.

Hi @Kriegelw that looks like a pretty old image and indeed I can’t find it on docker hub, not sure why. At some point we changed the tagging scheme so maybe that’s the reason. Can you give me a link to the project?

I just did some digging around and it looks like the image renku/renkulab-py:3.7-0.7.3 has the renku CLI version 0.12.1 inside, so potentially you could switch to that image if it’s necessary to keep the same renku version. To change the image, you need to edit the FROM line of your Dockerfile, commit, and wait for the build to complete.

Hi @Kriegelw, I’ve done a migration of your project in a fork with these steps:

  • I launched a session using the “Start with base image” button
  • I opened a terminal and made sure I have the latest renku version with
~/.renku/venv/bin/pip install -U renku
  • I ran renku migrate
  • I reset the template (to update all the CI files etc.) with
renku template set -f
  • I set the version of renku to 2.3.2 in the Dockerfile (for some reason it was left as None which is likely a bug
  • I used renku save to commit and push all the changes

After the image built I could get into the updated session.

Please beware though that this procedure deletes your requirements.txt, but this might not be a bad thing since yours had a lot of dependencies in there that are probably not needed (like pinning a jupyter version). I suggest you find the minimum number of dependencies that are required for the project and pin those through the requirements file. If you absolutely need to restore your requirements file you can do so with git checkout <commit> requirements.txt (look up the last commit before you did any of my steps above with git log) - but in this case you might be getting some pretty old libraries into the environment.

Let me know whether this works for you!

Hi @rrrrrok, this has indeed fixed the issue thank you!

Hello again,

I tried to run these steps on another project I have and receive the following issue when I try to use
renku migrate. Would you know what to do here?
I tried upgrading renku but the same error appears.

You probably have a git merge conflict committed in the metadata in .renku/metadata/, so there’s merged markers like <<<<<<<, ========= and >>>>>>> in the mfiles that were accidentally committed.

The next release of Renku will contain a fix that makes this error more understandable, but there’s not really anything we can do to on our end. You’d have to find and resolve the conflict in the affected file.

Having the renku merge tool installed can help prevent ending up in this situation.