Renku run breaks renku-cli

I have updated two files that are contained in the same dataset with a python scripts (via renku run …). Command was

renku run --name parliamentdb_conversion --input modules=conversion/ --input sqlite_iterator=conversion/ --input sqlite_handler=conversion/ --input translations=conversion/resources/translations --input scripts=scripts --no-output-detection --output rdb=data/democrasci_parliamentdb/democrasci_parliamentdb_rdb.db --output graph=data/democrasci_parliamentdb/democrasci_parliamentdb_graph.dump -- python conversion/ --schema conversion/democrasci_schema.yaml --constraints conversion/resources/unique_constraints.csv --delete --iterator data/parliamentdb/parliament.db --output data/democrasci_parliamentdb/democrasci_parliamentdb

git log successfully prints the renku commit. But now some renku commands return the error below. I have tried renku log and renku dataset update -a, both fail with the same error. renku dataset ls still works normally.

I have already submitted a github issue, but I need a faster fix as my renku is broken now. Can I somehow easily fix this? Reset the renku metafiles or similar?


Renku version: 1.5.0
OS: Linux (#194-Ubuntu SMP Thu Jun 2 18:54:48 UTC 2022)
Python: 3.7.12


Traceback (most recent call last):
  File "[...]/site-packages/renku/ui/cli/", line 134, in main
    return super().main(*args, **kwargs)
  File "[...]/site-packages/renku/ui/cli/", line 93, in main
    return super().main(*args, **kwargs)
  File "[...]/site-packages/click/", line 1053, in main
    rv = self.invoke(ctx)
  File "[...]/site-packages/click/", line 1659, in invoke
    return _process_result(sub_ctx.command.invoke(sub_ctx))
  File "[...]/site-packages/click/", line 1659, in invoke
    return _process_result(sub_ctx.command.invoke(sub_ctx))
  File "[...]/site-packages/click/", line 1395, in invoke
    return ctx.invoke(self.callback, **ctx.params)
  File "[...]/site-packages/click/", line 754, in invoke
    return __callback(*args, **kwargs)
  File "[...]/site-packages/renku/ui/cli/", line 1115, in update
  File "[...]/site-packages/renku/command/command_builder/", line 296, in execute
    output = context["click_context"].invoke(self._operation, *args, **kwargs)
  File "[...]/site-packages/click/", line 754, in invoke
    return __callback(*args, **kwargs)
  File "[...]/site-packages/inject/", line 342, in injection_wrapper
    return sync_func(*args, **kwargs)
  File "[...]/site-packages/renku/core/dataset/", line 761, in update_datasets
    _update_datasets_files_metadata(client, updated_files, deleted_files, delete)
  File "[...]/site-packages/renku/core/dataset/", line 1040, in _update_datasets_files_metadata
    datasets_provenance.add_or_update(dataset, creator=get_git_user(client.repository))
  File "[...]/site-packages/renku/core/dataset/", line 110, in add_or_update
  File "[...]/site-packages/renku/infrastructure/gateway/", line 87, in add_or_remove
    database["datasets-provenance-tails"].pop(dataset.derived_from.url_id, None)
  File "[...]/site-packages/renku/infrastructure/", line 661, in pop
    return self._entries.pop(key) if default is MARKER else self._entries.pop(key, default)
  File "[...]/site-packages/renku/infrastructure/", line 434, in setstate
    data = self._storage.load(filename=self._get_filename_from_oid(object._p_oid))
  File "[...]/site-packages/renku/infrastructure/", line 819, in load
    data = json.load(file)
  File "[...]/json/", line 296, in load
    parse_constant=parse_constant, object_pairs_hook=object_pairs_hook, **kw)
  File "[...]/json/", line 348, in loads
    return _default_decoder.decode(s)
  File "[...]/json/", line 337, in decode
    obj, end = self.raw_decode(s, idx=_w(s, 0).end())
  File "[...]/json/", line 355, in raw_decode
    raise JSONDecodeError("Expecting value", s, err.value) from None
json.decoder.JSONDecodeError: Expecting value: line 15 column 1 (char 455)

I replied on the issue you created