Trying flights tutorial, problem with using renku update

Hello, I am new to Renku and I am trying to go through the following tutorial: First Steps Tutorial — Renku documentation.

When I try the Build a reproducible workflow > Update your results, I get an error when I call

renku update -all
I get a very long log message, including
Writing failed [Errno 2] No such file or directory: ‘tmp/avirphlu/.cache/black/20.8b1/tmp1_8anv1r’
And I don’t see modifications in 01-CountFlights.ran.ipynb after updating I then tried to run 01-CountFlights.ipynb again, but now I get the same error and
data/output/2019-01-flights-count.txt is unchanged and
renku status
give me some Outdated outputs and Modified inputs no matter how many times (OK, once should have been enough) I try to call ranku update --all!

I am confused on how I should use renku update and on why it is not updating data and notebooks as expected. Could someone help?


Hi! I do not see anything obviously erroneous in what you posted. Is your project on RenkuLab? If so, could you post a link to it? (You may need to make it internal or public so I can see it.) I can take a look at the project to better understand what is going on.

Yes, the project is on RenkuLab and I just made it public. Looking at the output files (.csv and .txt in data/output/), the renku update –all command seems to have worked fine (I changed ‘AUS’ to ‘CLE’ in to test a new change). However, I expected to see 01-CountFlights.ran.ipynb to be updated with a modified output after I change and run renku update –all, but it does not.

In the very long output when I call renku update –all I see “Writing failed: [Errno 2] No such file or directory: “ which might or might not be related to my issue.

Thanks for making the project public. I’m looking into it and trying to reconstruct exactly what happened. Looking at the history for data/output/2019-01-flights-count.txt, I see the first version is in commit 805a557e and produced this content:

diff --git a/data/output/2019-01-flights-count.txt b/data/output/2019-01-flights-count.txt
new file mode 100644
index 0000000..2745edf
--- /dev/null
+++ b/data/output/2019-01-flights-count.txt
@@ -0,0 +1 @@
+There were 23078 flights to Austin, TX in Jan 2019.

The next version is in the commit d852d61d, which is the result of a renku update --all and produced this modification:

diff --git a/data/output/2019-01-flights-count.txt b/data/output/2019-01-flights-count.txt
index 2745edf..b3cc5e4 100644
--- a/data/output/2019-01-flights-count.txt
+++ b/data/output/2019-01-flights-count.txt
@@ -1 +1 @@
-There were 23078 flights to Austin, TX in Jan 2019.
+There were 4951 flights to Austin, TX in Jan 2019.

Then I see in commit 3e20d415, that you changed the search string to CLE (as you mention above). After that, you ran a renku update --all and that produced

diff --git a/data/output/2019-01-flights-count.txt b/data/output/2019-01-flights-count.txt
index b3cc5e4..8c2dcfa 100644
--- a/data/output/2019-01-flights-count.txt
+++ b/data/output/2019-01-flights-count.txt
@@ -1 +1 @@
-There were 4951 flights to Austin, TX in Jan 2019.
+There were 3907 flights to Austin, TX in Jan 2019.

So the history of changes all look good.

I’m not sure why you were encountering these errors. In any case, I do not see any trace of them in the history of the project.

As for why a renku update --all might not change the content of the file. I’m guessing that what is happening here is that you need to close and re-open the file to see the updates. I think JupyterLab is not noticing that the file has been updated and so the content is not refreshed. Closing an open view on the file and re-opening it should fix that.

I hope this helps!