Environment empty of files

Hi to all,

I am trying to start an environment for a repo I used a couple of months ago. Back then, it was working perfectly. However, when creating the environment now and accessing it, I cannot find anything in there but a folder called lost+found. But nothing more, none of the folders or files I can see on git.

The last Docker image was created perfectly, and inside the environment, I tried to switch the branch, but it is not possible as there is not any .git folder. What should I do?


hi @lusamino

it looks like git-clone did not work properly in your environment, this could be happening if you have more data (including LFS files if you enable auto-fetch) than the disk size you asked for when creating the environment. Could you verify and try requesting a bigger disk size than the size of the data?


Wow, it worked! Thank you so much @pameladelgado , and thanks to your super prompt solution!

However, I am still a bit puzzled because, according to git https://limited.renku.ch/gitlab/sluis/democrasci-machine-tr, the total size of the repo is around 11GB, which is not a lot. And most of those files are on LFS, and I never use auto fetch. In any case, it worked, fantastic! :smile:

Thank you so much
Best regards

Great to know it worked! :smiley:
Now that you have your environment up with the data you can inspect better the disk usage and see what is occupying the disk and by how much.


Inspecting now with du I cannot find the reason for that. After downloading a couple of things with lfs, still the disk usage of the repo is below 6G. I don’t know why that error happened in the first place. In any case, problem solved. Thank you so much!