Cannot upload data on renkulab

Dear renku team,

my collaborator would like to upload data to a project but it doesn’t seem to work. I don’t see any changes to the project. She tried both yesterday and this morning.
Data upload worked last week and wasn’t an issue so far.

When she uploads data using renkulab, she gets a blank screen after the upload seems to be done. She does not receive an error message.

This is the project: Renku

Thanks in advance for having a look at it!

Cheers,
Lili

1 Like

Hi Lili,

I just wanted to confirm that we are on the same page. Your collaborator is trying to create a dataset and upload data through the ui using this interface?

Do you know how large the data files she is trying to upload are? Also is she using the option to upload a zip file and then have the UI unzip and upload the unzipped file in the project?

The dataset creation feature is still experimental and uploading files larger than 500 MB will not work very well and cause issues. Also we have noticed that there are issues when the unzipping feature is used.

So there are a few things you can try:

  • Do not upload a zip file and do not select the unzip options, just upload the unzipped files
  • Use the renku cli to upload the files and create the dataset

I just created a new private project, and was able to upload a dataset to it without any problems, so the feature fundamentally works, but there may be something about this situation that is causing problems.

Most suspicious would be either the size of the data being uploaded or the version of renku that is being used in your project. I will contact you to get more information.

Dear Tolevski

Yes, I am trying to upload via the UI. I tried uploading three files at once, (81.5MB, 250MB and 2GB). After reading your message and realizing that size may be an issue, i tried uploading just the smallest file, which unfortunatly also failed in the same way. The data is not zipped. It is just a regular csv file.
I also find interesting, that when I try reuploading, I receive the error “filename already exists” and I have to change the file name before making a second upload attempt.

What is the renku cli? I am happy to try this.

Thanks,
Marianne

Hi Marianne,

The easiest way to “use the renku-cli” is as follows:

  1. Start a jupyterlab session from the project page
  2. Drag and drop the files from your computer to the jupyterlab interface (this will upload them)
  3. Once the files are uploaded you can also move them to a different folder in your project (if you wish)
  4. Run the following command in the terminal to add them to a renku dataset
renku dataset add --create my-dataset-name paths/to/uploaded_file_1 path/to/file2 path/to/other/files/*csv
  1. Finally to make sure everything persists run git push in the terminal

Let me know if you have any issues or questions. Hopefully the instructions make sense.

Hi Tolevyki

Thank you for explaining how to upload using renku-cli. Unfortunatly I seem to be struggling to start a jupyterlab session from the project page. Where exactly can I find it?

Thanks,
Marianne

No problem, just follow the steps below:

  1. Navigate to the project page using this link: Renku
  2. The above link should take you to a page very similar to the one below where you should click on “Environments” (circled in red)
  3. The “Environments” section looks like the image below, from here click on one of the two “New” buttons:
  4. This will lead you to the page that allows you to launch a jupyterlab session by clicking “Start Environment”:
  5. When you launch your environment it will take about 10 seconds or so before it is ready. When the environment is starting the little square on the left is yellow and it has a spinning animation

    when the environment is ready the square turns green, when it is ready click the connect button on the right
  6. When you click on the connect button, this will open a new window that looks like this.
  7. Drag and drop your files into the area on the left:
  8. To launch the terminal where you can execute the commands click here:

Thank you for the detailed description.
For me Step 6 appears differently, this is probably why I didn’t manage:

Hi Marianne

You opened the streamlit app. In step 4, change the default environment to /lab and you should get to jupyterlab.

That’s correct, or if you have an environment running already just change the last part of your URL and replace /streamlit by /lab, that would be: https://renkulab.io/jupyterhub/user/marianne.cockburn/cowdata-b201d8c4/lab

It seems to be a version problem.

Dear Marianne,

I am looking at the project and there seems to be a discrepancy in versions as reported through different channels. We will look into it and get back to you. Thanks for your patience!

Dear Marianne,

it seems that the renku-python version in your environment is out of date, but the project itself has been migrated to a newer version already. You can check this by running renku --version in the interactive environment, which should be 0.13.0 but is 0.10.4 in your case.

You could manually update renku-python by running pipx upgrade renku and then running renku migrate in the interactive environment. But that would only be a temporary solution, as you would end up with the wrong version of renku-python again when the environment gets restarted, as the Dockerfile in your project refers to an old version of renku-python (So the change wouldn’t be permanent). We support automated upgrade of the Dockerfile through the UI, but only if the Dockerfile supports it.

To enable automated upgrades of the Dockerfile, you’d have to edit it by replacing its content with renku-project-template/Dockerfile at master · SwissDataScienceCenter/renku-project-template · GitHub . After this change, the UI should be able to keep your Dockerfile up to date for you in the future (it will tell you that there is an update that can be done and update the Dockerfile when you click the button to update the project). It might take a while for the UI to see this change (up to 1 day, I believe), so in the meantime you might still want to also execute the pipx upgrade renku command mentioned above.

1 Like

Dear Ralf,

I updated the Dockerfile as you suggested and it worked. The renku version was updated within an hour (or a bit less).

Thanks!
Lili

Hello @tolevski and @cramakri !

My collaborator and I are having the same issue on a private project, when attempting to upload data from the UI. We fill the form to “Add Dataset”, click “Create Dataset” and it links to a blank page. Console log:
2.8aaeb9ea.chunk.js:sourcemap:2 TypeError: Cannot read property ‘identifier’ of undefined
at Dataset.container.js:60
at hs (2.8aaeb9ea.chunk.js:sourcemap:2)
at wl (2.8aaeb9ea.chunk.js:sourcemap:2)
at t.unstable_runWithPriority (2.8aaeb9ea.chunk.js:sourcemap:2)
at Gi (2.8aaeb9ea.chunk.js:sourcemap:2)
at El (2.8aaeb9ea.chunk.js:sourcemap:2)
at 2.8aaeb9ea.chunk.js:sourcemap:2
at U (2.8aaeb9ea.chunk.js:sourcemap:2)
at MessagePort.k.port1.onmessage (2.8aaeb9ea.chunk.js:sourcemap:2)
(anonymous) @ 2.8aaeb9ea.chunk.js:sourcemap:2
2.8aaeb9ea.chunk.js:sourcemap:2 Uncaught TypeError: Cannot read property ‘identifier’ of undefined
at Dataset.container.js:60
at hs (2.8aaeb9ea.chunk.js:sourcemap:2)
at wl (2.8aaeb9ea.chunk.js:sourcemap:2)
at t.unstable_runWithPriority (2.8aaeb9ea.chunk.js:sourcemap:2)
at Gi (2.8aaeb9ea.chunk.js:sourcemap:2)
at El (2.8aaeb9ea.chunk.js:sourcemap:2)
at 2.8aaeb9ea.chunk.js:sourcemap:2
at U (2.8aaeb9ea.chunk.js:sourcemap:2)
at MessagePort.k.port1.onmessage (2.8aaeb9ea.chunk.js:sourcemap:2)

Thanks in advance for your lights!

@charlottegiseleweil Oops! Is this on Renkulab or a different deployment?