"Can not clone repo" error - git file size/number

I’m getting this error

Error: Cannot clone repo from https://renkulab.io/gitlab/omnibenchmark/omni_batch/mnn-omni-batch.git

when trying to update a dataset from the above repository in another project by running:

renku dataset update omni_batch_mnn

I think this is associated to a git file size/number problem in the repository where the dataset originates from → origin_repo

In that repository the pipeline failed with an “RPC failed:curl52” error like in this this and this post, which I could resolve by setting GIT_DEPTH: 1 in the .gitlab-ci.yml file. Also I’m able to clone the repositry with ssh, but not with https.

The newly generated files, which are also the ones that are part of the dataset, that I tried to update, are stored in GIT LFS. So I’m wondering about the underlying problem and/or if there is a way to renku update/import this dataset?


I’m sorry - It turned out that this was not directly related to Git LFS or similar.
Instead the repository itself was corrupted (I’m still not sure why/how this happened) and thus couldn’t be cloned.
Finally re-initializing renku and/or gitlab housekeeping fixed the corrupted repository problem and the dataset can be imported/updated again.

1 Like