Renkulab PyPI Repository

I tried to push a wheel package to my Renku GitLab repository but getting error 404, am I doing something wrong or is usage of the PyPI repository in Renku not enabled?

1 Like

Hi Pascal!

thanks for reaching out!

I’ve just tested the functionality (hosting a pypi package on gitlab) based on the tutorial found here.

i’ve used Authenticate with a personal access token solution to authenticate with the registry.

in the ~/.pypirc the repository URL was set to:

using these i’ve successfully managed to publish a pypi package in the gitlab registry.

could you maybe share the URL you’ve set in your pypirc?
as based on the tutorial in case of renku’s gitlab instance you should set it the following way:<project_id>/packages/pypi

NOTE: it’s the project ID and not the project’s name. you can find this information when you view your renku project on gitlab and on the project details page it is right under the project’s name.


Hi Viktor!

Thank you for taking the time to look into my problem. I tried the authenticate with job token from the same tutorial. This is the repository itself.
I saw that I used instead of, and also omitted /gitlab/ from the url. Using the correct URL fixed the issue, thank you very much!

1 Like

btw, thanks @pascal.baumann for bringing this up, I wasn’t even aware that GitLab can function as a PyPI package registry… :sweat_smile: :raised_hands:

1 Like

You are welcome :smiley:
The repository is now updated with CI/CD and works, but is most definitely not implemented in a best practice kind of way though :sweat_smile: