Opening JupyterLab in separate tab doesn't work


When trying to open the JupyterLab interface of a session in a new tab using the “Open in new tab”, this leads to a 404 Error.
Previously, the url this button lead to was “[GITREPO]-[SESSIONID]/lab/workspaces/auto-X”, which still works when you replace the session id with the active one. Now it is "[GITREPO]-[SESSIONID]/lab?", and this gives a 404 error.

Hi @vjung99 can you give me a bit more information so that I can help you resolve this:

  • are you running a separate / custom image where you have something other that jupyterlab?
  • what is the value of RENKU_BASE_IMAGE in your projects Dockerfile?
  • what happens when you open the session inside the same tab (and not in a separate tab) does that work as expected?

I just saw that the project you are referring to is accessible to any user of limited. So I tried to launch a session from the same commit you showed above and things worked. I can open the session in a new tab or in the same one.

I wonder if this is a problem with browser compatibility. I tested this in chrome. But it could be that different browsers behave differently and do not handle the redirects as expected. Which browser are you using for this?

Hi @tolevski,
Thanks for the quick answer.

  • No, I’m not using a custom image.
  • It’s renku/renkulab-cuda10.0-tf1.14:0.7.4
  • It works as expected. I just can’t open it in a new tab.

I’m using chrome as well, on an M1 mac. It’s not a big deal since I can just input the session ID in the URL that works, but I do wonder why it works for you and not for me.

Can you try to do the same thing in an incognito window. It could be an issue with how your credentials are handled when you open a new tab. When you open an incognito window you will have to login again but if the problem persists then I can be certain the issue lies elsewhere.

Also if you have an ad-blocker or similar add-ons then try disabling them and see if that helps.

Yeah, it actually works in an incognito window. I don’t have any ad-blocker.

So if it works in an incognito window then you can get things going by fully logging out of renku and back in in your regular browser window.

To fully log out do the following:

  1. Go to and logout here first (you can do this by clicking on your profile picture in the upper right corner)
  2. Then go to and logout here as well

After this you should be fully logged out. And when you log back in you only need to visit and log in as usually. Then everything should work.