Git lfs autofetch depends on how you start the session bug

I’m preparing a session for a workshop and I noticed some unexpected behavior, I would be interested to see if others are seeing the same thing.

It appears that If I start a session by clicking ‘start’ on the project page or by following the session autostart link: Reproducible Data Science | Open Research | Renku then the git lfs files in my demo dataset are NOT pulled into the session but if I use the start with options dropdown to start the session then the files are pulled. i.e. Starting from this page: Reproducible Data Science | Open Research | Renku will autofetch the data but from the project home will not. This project has git_lfs_autofetch = true option in renku.ini Reproducible Data Science | Open Research | Renku

If I run the command git lfs fetch --all & git lfs pull then I can get the files in the sessions which don’t appear to be respecting the git_lfs_autofetch = true option in renku.ini then it works fine once the session is up it’s just not happening automatically.

Hello @RichardJActon

Thank you for the detailed description. We actually have a fix ready; it’s taking a bit longer to roll it out because it’s bound to more extensive changes around how we handle sessions. Hopefully, we will manage to include it in the next release to reach RenkuLab by mid-September.

In the meantime, the only workaround is starting the Session from the “Start session” page, as you already identified. That’s because the quick-start button doesn’t consider all the settings from the renku.ini file.

Sorry for the inconvenience.

Thanks - good to know there’s a fix in the roadmap


I have a private project right now on Renkulab with lfs_auto_fetch = true in .renku/renku.ini and I can confirm that files in the LFS are not being fetched automatically.

PS1 : my project uses renku_python v2.6.1
PS2 : but then your project seems to be using renku_python v2.3.2 :open_mouth: