Forking not possible


We are running a course and some of the students report that they can’t fork the latest project. Does anybody know what to do?

The link of the affected project is: Reproducible Data Science | Open Research | Renku

Thanks in advance,

That’s not good! This is a private project, could you give me (cramakri) access to this project so I can investigate the problem?

Thanks, I just added you.

Thanks! When I fork the project, I get a message like the following:


This situation is not a failure per se – the project was successfully forked (you can click the button to go to it), but additional work is necessary to start a session on this project.

For this project, the sessions use a shared, pinned image. But I cannot access the project that defines the image. Could you give me access to that project as well?

Thanks. I can also fork and run the session without any issues. However, for several students the „fork“ button doesn’t work, they also tried different browsers.

Just in case, I also gave you access to the pinned image.

Can you describe what the users see when they click the fork button? Ideally, if possible, with screenshots.

@cramakri Hello, I’m one of the students of FFopp. When I try to fork from Renku, there is no response at all.

this page just stays the same.

Since as a new User I can only embed one screenshot at a time, I’ll post the rest in separate replies

When I try to fork from Gitlab, it tells me that I already have a fork, which is not true.

Then when I click the “go to your fork” button, I am redirected to a different Gitlab repo (a previous practical of the course).

Does this help to determine the problem?


Yes, this does, thanks a lot! I can recreate this problem.

For the moment, there should be a workaround. You should still be able to fork the project from the main page of the project, where you go when you click follow this link 05-conservation-planning:

Could you try to fork it that way? That should work until we are able to fix the bug that you have identified.

I’m glad it’s not just me! I tried that, but unfortunately, in my case the button is not clickable:

Wow, sorry about that!

I’m assuming this has something to do with the way you have been given access to the project (you are a member of a group that is allowed to access this project), but so far, I have not been able to re-create this problem.

I gave Luuk now access as an individual member as well. Let’s see if that helps.

Thank you, I just tried but everything is still the same as before :frowning:

Oh, I have managed to recreate the problem. It is caused by an interaction between how the project is made accessible to these users (by giving a certain group of users access to a namespace of projects) and the fact that the project is private.

In my tests, adding the user directly to the project (even with access level “REPORTER”) fixed the problem. You may need to refresh the browser, though, before the fork button becomes accessible.

That should at least temporarily fix it, but we will investigate the source of the problem, since it is clear that classes need a more controlled way of giving a group of students access to the materials.