Streamlit app doesn't connect

Dear Renku team!
A collaborator, Marianne, would like to open a streamlit app from renkulab but it cannot connect… it remains at Connecting...
It’s from this project

She works from within the federal network which is very restricted (she cannot use zoom for example). Could this also be the cause that she cannot connect to renkulab?

Thanks for having a look at this!

Please let me know if you need rights to that repo or something else.


Marianne can open Jupyterlab. Maybe it has something to do with the streamlit settings in

Hi Lili,

thanks for posting this and granting me access to the project.

This could definitely be a reason, do you know details of the restrictions she might have?

Could you also please ask her to start an environment (with few resources) and leave it running so that we can check eventual log errors?



Could you also please try to start an environment from this project and let us know if you have the same result?

Could you also provide information about your OS, web browser?


Hi Pamela

I tried using Firefox and Edge, both with the same result. I have started an environment and let it run. It just comes up with “please wait…”. -
Could I can start an environment in the demo environment, but when I hit connect. Again it is not loading and says “please wait…”

Regarding: “When you started jupyterlab, did you also load the git lfs data? i.e. was the checkbox ticked?”. --> I am not sure what you mean.

Thanks and sorry for the inconvience,

Rephrasing the question: When you started the environment with /lab, did you leave the checkbox Automatically fetch git lfs data ticked?

I changed the ending of the link that opened. Instead of “/streamlit” I typed “/lab”

If you have an environment running, could you stop it? And then start a new one from the last commit (timestap today 16:14)?

The last commit is 9:51.

I think that’s when you started the environment. When you go to New, can you see this commit?

Now I can, yes. It still comes up with a new tab: “please wait…”

Thank you for trying that!

@pameladelgado: I commented the line with '--browser.serverAddress', '', in since this is the only line which is both in this project and the demo project. For me, the app still opened without this line.

Hi Marianne

@rok would like to try something. Could you connect to the streamlit app again but this time having a look at the network log in your browser? See here for how to view the network log:

Thanks a lot,

Hi Lili

Yes sure. From the federal network or the private one?

Hi Lili

This is a screenshot within the federal network.

And another screenshot from the federal network when I try connecting to the dashboard.

1 Like

@Marianne: thanks a lot!

@rrrrrok: Does this help?

Hello @Marianne and @LiliGasser ,

The screenshots are definitely helpful. It seems that the connection to the WebSocket Secure protocol to is blocked. That may definitely be enforced by a corporate firewall.
To be sure that’s the case, I would try to connect from a different network and launch the same environment. You could perform a reliable test by using a private phone with WiFi turned off, or using a private PC connected through WiFi at your home.

If that works, the only thing you can do is asking your IT to unlock the connection to on the wss protocol (WebSocket Secure). There is no way to use Streamlit without WebSockets.

I hope this helps!

Hi Lorenzo

Thanks for your Mail. Streamlit works fine on a private computer, so I can confirm it is the problem. Unfortunately, we have no chance to unblock anything within the federal network, but at the moment it is no problem for me to work on the private computer outside the network. Interestingly I can upload data while in the federal network. I am saying this, because this is very helpful as it means I do not have to transfer big data sets to a private computer before uploading them to Renku and I can imagine it may be useful information for future collaborations within the federal networks.

1 Like

Good to know that!
All the RenkuLab features available outside Interactive Environments should work fine, as they don’t require WebSockets. The bad news is that we will use that technology elsewhere in the future. It’s very valuable and many modern web applications are using it nowadays.

It’s surprising that it’s blocked in the federal network. Hopefully, that policy may change in the future to keep up with the new technologies :crossed_fingers: