RStudio version too old

I am running the following project Renku and hit this warning

> ls()
Warning message:
R graphics engine version 14 is not supported by this version of RStudio. The Plots tab will be disabled until a newer version of RStudio is installed. 

And indeed, when plotting

> plot(1:10)

I don’t get an figure in the plot panel but it is produced in a pdf file.

This is easily fixed with a more recent version of RStudio, but I’m not show if/how I can do that.

@lgatto I am looking into how to update Rstudio and get past this error. I will post here again once I have a solution.

1 Like

Hi @lgatto I see that you switched to using the renkulab image called renkulab-bioc:RELEASE_3_13-c1b18cb in your project. However this is not yet officially supported in renku - what you got there is just a development build that we used to test. Official images will not have a string of 7 random characters at the end but rather something human readable or a proper semver (i.e. 0.8.0). So the latest official build is renku/renkulab-bioc:RELEASE_3_12-0.8.0.

The problem we are having is coming mainly from the latest version of Rstudio (1.4.1717) which would enable you to use R version 4.1.0 and the latest version of bioconductor (3.13). However the latest release of Rstudio has some changes in how it handles the authentication that do not play well with our current setup and we therefore cannot yet use it with renku.

An interim solution for now would be to simply downgrade to renku/renkulab-bioc:RELEASE_3_12-0.8.0 which has bioconductor 3.12 and R version 4.0 and will work without any problems with the Rstudio version we use in Renku.

Or if the only issue you have is some limited functionality in plotting in Rstudio but everything else is ok then I guess you can also stick with your current setup.

I will do a bit more digging of whether there have been any new developments in the issues we have encountered with the latest Rstudio version and let you know if there is a way forward. However it seems that this is not something we can resolve very quickly.

1 Like

Thank you for getting back to me @tolevski.

I understand the technical difficulties of keeping up with third party changes on top of all the great work you already do. I just want to highlight that it is important for R/Bioconductor users to have access to the latest version of Bioconductor, which is release 3.13, that requires R 4.1.

1 Like

Hello - I was wondering if there was any update on this front? Thanks!

Hi @lgatto,
I’m not well-versed with the entire R ecosystem and I haven’t looked into this myself. However if this is a problem with the Jupyterhub based authentication of the user sessions as described by @tolevski, then we’re not talking about us keeping up with upstream changes, but rather two formerly compatible 3rd party components in our stack not being compatible anymore.

The good news is that we are currently doing a complete refactoring of how we launch, manage and expose user sessions. This also includes authentication. I’m hopeful that once we have this refactoring rolled out (which is probably in a month from now) this authentication issue will be gone.

@lgatto the reported authentication problem was actually somewhat of a red herring. should contain the current versions of r and rstudio. Can you confirm that? If yes, we should be able to release a new version of our base image which works with what’s currently deployed on in the next days.

1 Like

Thanks @andreas - I’m assuming that the test implies setting

FROM ableuler/renkulab-r:rstudio-fix

in my Dockerfile. This is running not and I’ll let you know here how it turns out.

Sorry, I might have jumped to conclusions too quickly. While it’s quite easy to make such an image work locally (what I did above), it doesn’t yet work in a JupyterHub context. So it looks like we have to wait until this issue is resolved and there’s a new release of the jupyter rsession proxy. @tao.sun has actually been looking into this in more detail than I have.

Ok, thanks. And I assume that to test locally, I need to have a local renku installation, right?

docker run ableuler/renkulab-r:rstudio-fix
fatal: repository '//renku-env.git' does not exist
find: ‘/tmp/renku-env’: No such file or directory
Error: `.` is not a renku repository.
To initialize this as a renku repository use: `renku init`
chown: changing ownership of '/home/rstudio/.rstudio/projects_settings/next-session-project': Operation not permitted
chown: changing ownership of '/home/rstudio/.rstudio/projects_settings': Operation not permitted
JUPYTERHUB_API_TOKEN env is required to run jupyterhub-singleuser. Did you launch it manually?

No, by testing locally I mean running the image in docker directly, eg
docker run --rm -ti -p 8888:8888 ableuler/renkulab-r:rstudio-fix --ip=

Ah, ok thanks. This opens a jupyter notebook, but I would need a functioning RStudio instance to check the issue I reported. Let me know if there’s anything I can help with. Thanks!

Yes, you have to browse to /rstudio manually after the notebook has opened.

1 Like

That seems to work indeed!

There’s that rstudio warning/message at the top that doesn’t seem to affect a simple usage, as far as I can say.

Hello - any updates on this on the Renkulab side? The ableuler/renkulab-r:rstudio-fix image works, but I still have the issue on Renku. What changes do I need to do to benefit from that fix. I seem to have updated my Dockerfile, but without success.

Hello @lgatto, we are still waiting for jupyterhub to fix this issue in order to make rsession work properly in jupyterhub.

I create another image st714/test:bioc-fix with RStudio=1.4.1717 , R=4.1.0 , bioc=3.13 and an unreleased version of jupyterhub-rsession-proxy. This image works on RenkuLab.

You need to change default_url in renku.ini from /rstudio to /rstudio/auth-sign-in?appUrl=%2Fworked to make it work properly.

For details, you could check this project. Let me know if it works for you.


Thank you very much @tao.sun - I’m giving it a test at the moment and will report back here.

Hi again - sorry, I don’t seem to get it working, as I get prompted for a login and password, and rstudio and rstudio don’t work. Could it be due to the next line in renku.ini?

image =

Hi @lgatto, yes, I think it’s about this line. The session will start with this pinned image instead of the recent one.

I’m building a new image at the moment (it takes quite some time to build) with a clean renku.ici. Will let you know later. Thanks again for your help!