Pinned docker image not updated

Hi everyone,

I forked an existing project which had a pinned docker image. I made many changes, my image works, and now I finally pinned the project to a new docker image. I used both the interface (Settings->Sessions->Docker Image) and directly the command renku config set interactive.image The renku.ini file seems to be updated correctly (Reproducible Data Science | Open Research | Renku) but whenever I use just the Start button (without specifying an image) it reverts back to the old pre-fork pinned version. Any idea what else I should additionally fix? Thanks for your help!


1 Like

There is something strange going on here. The reason you do not see your image is that there is a commit with autosave information that is being automatically selected. If you pick the most recent commit, then the correct image is selected.

One problem is that the information that there is an autosave for this project is not communicated very well. This is something we are aware of and working on.

But the other strange thing is that an autosave exists and was selected for the the anonymous user, which I did not think should happen. That we will need to investigate.


You should be able to fix this problem if you go to GitLab:

and navigate to the “Repository > Branches” page. There, delete any branches starting with renku/autosave: that should fix the problem.

Thanks for the prompt answer! This did indeed solve the problem, thanks so much!

Is there any way to disable auto-save to avoid this problem?

It is not possible to disable autosave for an individual project, but we have some improvements planned that should correct the problems you are encountering.