Nothing tracked due to this error

Hi to all,

I am tracking inputs, outputs and parameters through the Renku api. I have had this error many times, causing the workflow to not be tracked

Error: Invalid parameter value - Duplicate input, output or parameter names found: use_embeddings

This is the definition of that parameter:

_ = Parameter(name="use_embeddings", value=args.use_embeddings)

where args.use_embeddings is a str. I have tried a few things: cleaning with renku gc, commenting this (and then it gives the same error with another parameter). But I cannot understand what is going on. In the beginning, as value I was providing True, and I thought that might be the reason. But now, I just provide a str. What is going on?


Wow, writing this has been a revelation. I feel I know the error. The command is:

renku run python src/ --nr_topics 300 --use_embeddings False --remove_entities False

Hence, I believe these 3 parameters are tracked twice: internally, and from the command use to run. Hence, I understand the error, but there is still en extremely annoying this: could this be checked before actually running the whole thing? And then renku prompting: Duplicated inputs, please do something. Each simulation takes around 1h, and it has been already a few. What are your thoughts on this?

Cheers, and thanks for the inspiration :stuck_out_tongue_winking_eye:

:pray: Thank you for sharing this issue. It will definitely help to improve the error information display.
:question: Have you managed to run the command correctly? (I am sorry that I do not completely get it from your description if you could solve the issue).

HI @elisabetc! Thanks for your response! Yes, I modified the script to not track internally the parameters provided when running the command, i.e. nt_topics, use_embeddings and remove_entities, and then it runs. However, I don’t think something like this should prompt an error, and even less, after the whole execution. For that reason, I do think this behaviour needs to be revised.


Great to hear you solved it :sparkles:. Indeed, I take note to revise this behaviour with the team and avoid it in the future! Thank you again @lusamino :pray: