Job's log exceeded limit of 4194304 bytes

The following job failed with message

Job's log exceeded limit of 4194304 bytes.

I couldn’t immediately find a parameter to increase that limit - does anyone have a suggestion?

It looks like setting output_limit to a greater value is the solution. I am however not sure where to set it.

Edit I am trying with ~/gitlab-runner/config.toml.

Maybe try to use quietly = TRUE when installing packages.


Those are settings in the gitlab runner itself, which you don’t have access to. The best way to fix this is to do what @cchoirat suggested and reduce the verbosity of the package compilation. If you need to debug some step of the build, I suggest you try to build it locally where you have more control and once you’re happy that it works you can move it to renkulab. Happy to assist with the local part if you need!

1 Like

Thanks @cchoirat - that is very significantly reducing the output and should sort my problem.

Error: Failed to install 'Spectra' from GitHub

Would we need to update the BioC image to 3.12?

That’s what I’m doing at the moment, manually (with BiocManager::install(version = "3.12")) but it would be great to have the latest Bioconductor 3.12 docker ready.

(Note that the Spectra error is probably related to something else).

oh I didn’t realize there was 3.12 - I can add it to the build.

I’m wondering though if it would make sense to set this quietly = TRUE option per default in R projects - where would this normally be set in order to apply globally?

I’m not sure where to set this globally - I didn’t find it in the options. It’s a parameter to the package installation functions:

install.packages("one_package", quiet = TRUE)
BiocManager::install("other_package", quiet = TRUE)

If the installation goes wrong, there no message to debug.

Note also that in my case, a lot of extra output was repeat unnecessarily due to the new Bioconductor release:

Bioconductor version ‘3.11’ is out-of-date; the current release version ‘3.12’
is available with R version ‘4.0’; see`

Right - I tried to add 3.12 yesterday and they haven’t released their docker images yet. As soon as they do we’ll have a base image based on those.

Regarding the logs: is there no message in the case of a compilation error when you set quiet=TRUE?

I am not sure if all or only some messages are silenced in case of error. I had an R-level error yesterday that didn’t show up.

Is there a quiet = sometimes option? :slight_smile:

Would be great if we can have some default here that would work for most people - it’s pretty frequent that really long-running builds fail due to the max log restriction and it’s very frustrating for everyone. If you land on some configuration that you think would work well please let me know and we’ll build it into the templates.

Maybe pre-build and/or cache packages along the lines of