Problem running local renku session

I am trying to run a public repo of mine locally with renku session, however, I am running into same issue with both linux and macOS.

  1. Linux (Ubuntu) workstation:
    First I installed renku via pipx and renku is indeed in my PATH.
    Try running a session:
renku session start --disk=20G --memory=8G --cpu=4 --port=8892

which returns:

Your user id is not 1000 and for Jupyter to work the session must be started as root.
Jupyter itself will run as your user.
Starting as root has security implications, make sure you trust this Dockerfile.
Proceed? [y/N]: y
Warning: Cannot start a session with the disk request: Ignoring the disk request
The session for ‘’ has been successfully started. It is available at:

However I get the following screen at the corresponding notebook url:

I don’t know if this is because I am not root on Ubuntu workstation.

  1. I also tried doing it locally on a macOS:
    I installed renku as before and then cloned the project repository. Inside the repository, I tried launching a renku session as follows:
    renku session start --disk=20G --memory=8G --cpu=4 --port=8893
    With this one, I get the exact same message of “A Jupyter Server is running.”

I am clearly missing some final step, but cannot figure it out.

Ah you can just add /lab to the url and it should work. We should do that automatically.

That was indeed the problem. Please add that to instructions!

Thank you @firat , we will do :pray:

I think I’ve seen similar behaviour for rstudio when starting that locally too - I’ll have to check. Is there a github issue for this that I could add this too if it turns out to be the case?