Ignoring files in renku templates

I’m working on a Renku template for bookdown which has a .tex file in the project to specify the latex pre-amble if you build a pdf from your bookdown project. Because of LaTeX syntax this does not play very well with a templating tool that uses a lot of {s there’s nothing in the file that needs parameterising so I was just going to exclude it from being processed by the templating tool and be copied raw rather than mess around trying to escape things. I tried setting _copy_without_render to exclude all .tex files in a cookiecutter.json file based on the cookiecutter docs but this doesn’t seem to be working.


    "project_slug": "{{ __project_slug__ }}",
    "_copy_without_render": [

However I still get an error when creating a project from the template as soon as I add the offending .tex file to the repo. Does anyone know if I’m on the right path with this approach?

I’m working on my bookdown template in: Files · bookdown-debug · Human Developmental Biology Initiative (HDBI) / HDBI Renku Templates · GitLab

Aside from my specific issue I think if might be a useful thing to have to have how to include ‘raw’ files in templates and basic escaping mentioned in the Renku templates docs