# Error during Environment creation

**URL:** <https://renku.discourse.group/t/error-during-environment-creation/407>\
**Category:** General\
**Created:** [7 September 2021 10:36 UTC](https://renku.discourse.group/t/error-during-environment-creation/407 "2021-09-07T10:36:46Z")\
**Posts on this page:** 1\
**Showing post:** 7

<div class="post-metadata">

**Author:** ![ralf.grubenmann](https://yyz2.discourse-cdn.com/free1/user_avatar/renku.discourse.group/ralf.grubenmann/32/78_2.png) [@ralf.grubenmann](https://renku.discourse.group/u/ralf.grubenmann)\
**Post date:** [8 September 2021 07:01 UTC](https://renku.discourse.group/t/error-during-environment-creation/407/7 "2021-09-08T07:01:37Z")

</div>

The problem is that we use pipx in the images to install renku, which uses a different environment than where requirements.txt dependencies end up in. So pinning in requirements.txt has no effect on the pipx install.

Doing `/home/jovyan/.local/pipx/shared/bin/pip install setuptools==57.5.0` in the Dockerfile before the entry that installs renku works. But it seems a bit hacky, I’m not sure if there’s a better way to install something in the shared environment used by pipx.

e.g. adding a `RUN /home/jovyan/.local/pipx/shared/bin/pip install setuptools==57.5.0` here should work: [renku-project-template/Dockerfile at master · SwissDataScienceCenter/renku-project-template · GitHub](https://github.com/SwissDataScienceCenter/renku-project-template/blob/master/python-minimal/Dockerfile#L34)

---

_[View the full topic](https://renku.discourse.group/t/error-during-environment-creation/407)._
